Page 1 of 1

Hard drive randomly unresponsive, please help.

PostPosted: Sat Nov 02, 2013 9:10 pm
by pierovera
Hey everyone,

I've been having a strange problem with my hard drive lately, but before I explain in detail, here's a little overview of everything that you need to know. I'm using a Mac Mini (1,1 I think) with a 1.5GHz Intel Core Solo CPU, 2GB 667MHz DDR2 RAM, running Mac OS X 10.5 (Leopard). The hard drive I'm using is a LaCie P'9220 500GB drive, connected directly (I mean no USB hub or anything) through USB 3.0 to a USB 2.0 port (maybe it matters, IDK) with HFS+ Journaled file system and it's not partitioned. The drive is practically mounted all the time and rarely disconnected. The drive isn't my boot disk, it's simply a storage disk.

Now I don't know if that's essential or not, but still I thought it's worth mentioning. Now here's the issue. About 2 months ago, this hard disk started acting weird where it would randomly prevent me from writing to it, though I was still reading from it constantly as I was running applications and had open files located in the disk. I restarted the computer and it worked again, but it happened again later on. It's worth noting that the computer never gets turned off, and the intervals between these unresponsiveness events are about 1-3 days.

I tried modifying anything on the disk directly from the Terminal and it just spit out the same message in all cases, "Invalid Argument". Here's one of the attempts to create a directory, for example:

adminroots-computer:/ piero$ mkdir /Volumes/Piero\'s\ Lacie/test
mkdir: /Volumes/Piero's Lacie/test: Invalid argument


Being annoyed that I had to restart the computer every time this happened, I tried ejecting the disk and I believe it didn't work (though I'm not too sure). I tried linking this weird happenings to putting the computer to sleep, but I found out it happened without the computer ever going to sleep. Also I noticed just today that it had nothing to do with the disk being inactive, because I was downloading some files in parallel and the last file suddenly stopped, and guess what message popped up? "Download failed: Invalid argument" . The screensaver might have something to do, but I haven't yet been able to confirm or deny this.

Lately what I do to fix the problem is to unmount the volume, though there's another issue here as well. While unmounting, this message pops up:

adminroots-computer:/ piero$ diskutil unmount /Volumes/Piero\'s\ Lacie
Volume Piero's Lacie on disk1s3 failed to unmount


So I end up force-unmounting the volume because it refuses to unmount. After mounting it again it works perfectly once again. Note that I don't disconnect the disk after unmounting.

So, does anyone know what could be causing this? If so, how can I fix it?

Thanks :)

Re: Hard drive randomly unresponsive, please help.

PostPosted: Fri Nov 29, 2013 3:32 pm
by pierovera
So, no one? :|

Re: Hard drive randomly unresponsive, please help.

PostPosted: Tue Dec 03, 2013 4:07 pm
by Bjorn van Sinttruije
Sorry Piero, I wish I could help. I hope someone else can offer assistance.

- Bjorn

Re: Hard drive randomly unresponsive, please help.

PostPosted: Tue Dec 03, 2013 4:37 pm
by Bob Andersson
Hi pierovera,

I don't know what the problem is either but if it were mine I'd start by using another USB cable just in case you have a poor connector. If that doesn't fix it then if your USB drive doesn't contain data you have backed up elsewhere then maybe you could try formatting it with all the scan and repair options for the whole drive turned on. And if you don't have your data on that disk backed up elsewhere then now might be a good time to do just that just in case the LaCie is on the way out.

Bob.

Re: Hard drive randomly unresponsive, please help.

PostPosted: Tue Dec 31, 2013 5:03 pm
by pierovera
Sorry for the very late response, I've been away for a while. Thank you for your responses though.

Anyways, I do back up my data weekly, so I think I might go ahead and format it with all of those options you mentioned. Though I don't think the LaCie might be on it's way out, it's been around 3 years since I bought it and usually LaCies have lasted me around 10+ years.

Also, the cable isn't the culprit as I already tried a couple different cables.

I discovered that by having the computer never going to sleep, either keeping it on screensaver mode or turning it off altogether, I could keep the drive from going into this state. I have no clue as to what happens, but I've at least narrowed it down to what might be causing this.

Anyways, thank you :)