Page 5 of 6

PostPosted: Wed Nov 18, 2009 1:33 pm
by popo
It's getting on for a month since I built the win7 box, and I'm still configuring bits as I use them... haven't moved over my user files yet either. That's years overdue a sort out. Usually ends up in a folder called "from old PC" and I search through it for files as needed... I wonder how many generations are in there now...

PostPosted: Wed Nov 18, 2009 3:00 pm
by thelostswede
hahaha... that sounds so familiar, I have about 3-4 folders like from various upgrades and re-installations :lol:

PostPosted: Wed Nov 18, 2009 4:59 pm
by Bob Andersson
Hi folks,

Early testing showed that Photoshop, while working, was failing to recognise my NVidia GTX285 as providing GPU acceleration, this despite the fact that I was running the latest W7 x64 WHQL driver version 191.07. An update to the latest beta driver, v195.55, solved the issue allowing me to go into the Performance dialog box and enable OpenGL.

A number of the Asus supplied utilities for my P6T Deluxe motherboard seemed to be working fine after the upgrade from Vista x64 but I was getting some "Asio.sys" driver error messages when logging on. I uninstalled all the utilities and started again. Fortunately the only one I really wanted was the only one that worked, namely the OC Palm driver which allows me to display the output from a Yahoo widget in the little USB connected LCD screen - handy for flagging when new mail is waiting when the main screen is powered down. I tried installing some of the other Asus utilities but they either complained they couldn't install an ACPI driver (stupid because W7 is already running one) or would install successfully but generate that "Asio.sys" error. For the marginal use I made of the EPU6Engine's capability to automatically under and over-clock the motherboard I'm happy to wait unti Asus gets it's act together.

I'm coming to terms with the Taskbar flipping up and down from the bottom of the screen (better for me than having it permanently in view) and I guess I'll have to live with the lack of an old fashioned Start menu. The toy I'm most unhappy about losing is the Stocks gadget but in the grand scheme of things it's not too much of a sacrifice. And, having spent the last many years cajoling Windows to look and feel like Windows 95 I guess it's good that I'm finally being forced to work with a more modern UI. Or is it.... :?: :wink:

Oh, and one HUGE bonus, which has little to do with the forum, is that it seems that Media Center is finally taking note of the Genres I assigned to my DVD collection. 8)


PostPosted: Wed Nov 18, 2009 5:13 pm
by thelostswede
ASIO is a low latency audio driver, so you might have to upgrade your sound drivers.
The other stuff, try installing the in compatibility mode for Windows Vista and they might install properly.
Apart from the OC Palm utility, it seems like they have Win 7 versions in 32 and 64-bit for most of their other utilities for the motherboard in question.

PostPosted: Wed Nov 18, 2009 6:56 pm
by Bob Andersson
I'm not so sure about the availability of Windows 7 versions of the utilities but driver support is certainly there. Installing some of the utilities in compatibility mode might be an option but given the low level access to the motherboard required I'm not giving that one high priority right now.

One thing I did noice when I first saw the Windows 7 boot-up is that one of the Microsoft programmers might be using my software. :lol:
Oh, and one vital tip that I forgot to mention is that before starting the upgrade get in 500gm of the finest quality chocolate. :twisted:

Update: One other snafu as I'm being brutally honest and this one is equally relevant to the "fresh install" brigade as well as the upgraders. I've used Microsoft's Virtual PC software for a while to run an old XP Pro environment under Vista. Very convenient as closing the window just hibernates the Virtual PC. Windows 7 comes with Virtual PC built in and yes, you've guessed it, this newer version of Virtual PC was built without keeping compatibility with hibernated machines from the older version. As my other Vista machine is RAM limited I'm unable to open the hibernated virtual machine there which means begging a favour from a friend so that I can open the hibernated machine on his machine (with a fresh install of Virtual PC) and shut the virtual machine down in a more conventional manner so it can be converted by the W7 Virtual PC software. Did Microsoft really have to do this? Grrr! :evil:


PostPosted: Thu Nov 19, 2009 12:57 pm
by thelostswede
Have a look at the Asus support website, select your motherboard version and Windows 7 and you'll find the updated applications.
Never ever use the drivers CD that comes with your motherboard if you can avoid it, since the drivers are in general outdated unless you've got a motherboard that just launched.

PostPosted: Thu Nov 19, 2009 1:54 pm
by Bob Andersson
Do you know, I never thought of that. :P

Example: ASUS PC ProbeII V1.04.72 Install Program for Windows 32/64bit XP & 32/64bit Vista & 32/64bit Windows 7 dated 2009/06/24.
    Installs fine and when run it generates the Asio.sys errors.
I agree about your remarks concerning drivers on the motherboard CD but if you take a little time to read my earlier posts you'll see that I wrote "I'd spent a lot of time making sure the hardware drivers were Windows 7 compatible and I'd followed all of the advice of the W7 upgrade advisor so I wasn't expecting trouble" so I'm not quite sure why you think I'm in need of that particular gem. :evil:

A spot of Googling shows a lot of issues with the Asus utilities for Windows 7 (I'm running x64 Ultimate). The P6T Deluxe Windows 7 drivers are all fine (but I don't use the onboard LAN so I can't speak to that one) but for anyone considering W7 my advice is that if you rely on any of the utilities then maybe sit on your hands a while longer.

But thanks for the well intentioned advice. Appreciated although I'd already been there and done that.


PostPosted: Thu Nov 19, 2009 6:16 pm
by thelostswede
This post on the Asus support forums might help, as plenty more people seem to be having the same problem ... -us&page=1

PostPosted: Thu Nov 19, 2009 6:42 pm
by Bob Andersson
aaCenter is running even though I thought I'd uninstalled all the Asus utilities. I'm going to have to spend some time thinking about that before forcing removal. :?

Thanks for the link.


PostPosted: Thu Nov 19, 2009 8:45 pm
by Bob Andersson
Hi thelostswede,

Well, it was a brave attempt. I had actually noticed that thread before but had dismissed it due to the date of the first post. But I try to keep an open mind when I get specific advice so I did disable aaCenter (stopped the process and renamed the folder). Rebooted and uninstalled OCPalm and then tried installing the W7 version of PC ProbeII. Still got the Asio.sys error on starting that app. :evil:

Given the number of W7 beta utilities dating back to June this year for the P6T Deluxe motherboard with no sign of normal release versions I think the lack of utility support shown by ASUS for what was arguably the best of the first generation of X58 motherboard is pretty deplorable. That ranted, the only utility that I really need is OCPalm and that one works just fine in "Yahoo! Widget" mode. For overclocking and other system functions there are doubtless better third party solutions out there, as a quick search on the Net shows.

So, as this is a W7 compatibility thread, my advice stands. The P6T Deluxe board works just fine with W7 x64 but don't be surprised if you find that the utilities don't work or only work with some issues.

On another topic, the upgrade (not fresh install) problems I described earlier with respect to some AppData being orphaned also applied to the Windows Start menu. The top level folders were still there but quite a few subfolders and shortcuts had got left behind and needed manually copying over: and you have to drill down a long way into the old Vista folders to find the necessary entries. Particularly stupid as the corresponding applications were all present and correct with the registration status (registry entries) apparently intact. :roll: So while I did save time doing an Upgrade it has proved not to have coped at all well with my highly customised configuration here. Maybe it works better on simpler setups but I'll resile slightly from my previous stance and concede that a fresh install may be the better way to go for most if reinstalling the applications and restoring the data isn't too mammoth a task.


P.S. Just for the record, the "EPU-6 Engine" worked just fine under Vista x64. It only started misbehaving when W7 was installed.

P.P.S. That's it for the day. Time for a soak and a few chapters of P.G. Wodehouse... ;)

PostPosted: Fri Nov 20, 2009 6:55 am
by thelostswede
Well, I never ever upgrade my OS as it's generally just a waste of time, mostly due to what you've described in this thread. New hard drive, clean install of the OS and all the applications and then copy anything needed across from the old drive. That's also why I end up with tons of old backup folders with stuff in them that I never end up needing again, but somehow don't end up deleting :D

Shame about Asus, I thought they'd be more on the ball when it comes to these things. It's a very strange error, but at least you're not alone in having it as it seems. This is somewhat of a problem with many Taiwanese companies, they're good at hardware, but useless when it comes to software and even worse when it comes to fixing problems that relate to products that aren't brand new. Sadly I don't have a good contact at Asus any more, or I would've gotten hold of someone there and asked them about the problem for you. Had it been Gigabyte I could at least spoken to a few of my friends there...

PostPosted: Fri Nov 20, 2009 10:02 am
by Bob Andersson
Kind words and much appreciated. But knowing what I know now would I have done a fresh install? The answer is a resounding "No" because I've also read reports that the W7 installer has proved reluctant to load the drivers for and accept my unusual hard drive configuration. Strange as Vista showed no particular reluctance and it's always difficult to be sure whether such reports are down to finger trouble or a real incompatibility. I certainly hope I don't have to test it out for real one day! This was the first "serious" machine I've built in a while without an add-on RAID controller and while the motherboard's Marvell controllers work I think next time around I'll go back to Adaptec or Promise. But that's for another thread and another time...

Thanks again for being so on-side. 8)


PostPosted: Fri Nov 20, 2009 2:55 pm
by thelostswede
Yeah, I read about your SAS controller issues, very odd. I guess it's not a proven technology on consumer level motherboards, but loading drivers in Windows 7 is far easier than in previous Microsoft operating systems. You used to have to tap F10 like a crazy maniac before the first text appeared and then you had to say a quick prayer and hope that the install process would read the floppy disk you'd prepared and actually recognize the driver files.

Promise aren't what they once were, too much competition, although Adaptec still offer some pretty advanced solutions if you can afford them. Marvell seems to have pretty much taken over the consumer level market for add-on RAID controllers, although there are still a couple of other cheapo brands out there too. I haven't played around with SAS, but I do remember having had a similar issue with a HighPoint controller that required a separate firmware upgrade after the BIOS had been upgraded and it's a real pain in the...

This is when I understand why people buy Mac's, but I do quite enjoy tinkering with my machine. Just put together a Core i5 system and it's flying compared to my old Core 2 Duo machine. I didn't have any problems during the install though, but as I said, I never do upgrades any more, I think the last time I did that was around the Windows ME days :D

The auto overclocking utilities can be quite handy though, as they keep you within safe limits, but if you always want and need the full performance out of your system, then you should really do it all in the BIOS. These days most motherboards allow you to save multiple profiles, so as long as you don't mind re-booting to swap profiles, this might be an option as well if you're concerned about running the system overclocked at all times.

PostPosted: Tue Dec 01, 2009 6:49 pm
by Bob Andersson
Hi folks,

Today I successfully applied another W7 x64 upgrade (not fresh install) over Vista x64. The target machine was my Media PC which I use mostly to play DVDs, CDs and to stream Internet content. For all of these I use Microsoft's Media Center as my primary interface with Internet radio courtesy of the irreplaceable mcShoutcast and NASA TV courtesy of the now difficult to find NasaTv For MCE. I purposely didn't populate this machine with lots of codecs and other exotica as I had the advantage of coming late to the MediaPC party so I was able to ensure that all the content I wanted to play could be generated with the standard codecs in mind.

Hardware is an Asus P5E-VM HDMI motherboard, an Asus EN9600GT MATRIX/HTDI/512M graphics card whose HDMI output feeds an Asus Xonar HDAV1.3 sound card which injects 5.1 sound into the HDMI data stream. The graphics card also feeds the touch-screen LCD on the front of the Silverstone GD02B-MT case. I mention the latter in particular because one of the oddities of the system is that this is the screen that the graphics card uses to display boot-up information on until Windows loads the NVidia screen driver which then correctly allocates the plasma TV as the main display.

So, building on past experience, I made a note of a whole host of driver settings and again made sure my existing working configuration was fully backed up. I then applied the latest graphics driver and iTracker graphics card fan controller software, both downloaded direct from Asus and both compatible with Vista x64 and W7 x64. The W7 version of the sound card driver proved not to be compatible with Vista so after finding that out I rolled back to the previous driver. The other preparatory software upgrades were to the Asus bundled copy of Total Media Theatre and the iMon software which drives the information display on the case's touch-screen LCD. I also ran the Windows 7 upgrade advisor and cleared all the outstanding items it flagged.

With that done it was time to put the W7 x64 DVD in the drive and run Setup. This went a lot quicker than on my main PC (much less in the way of applications and settings to move across) but I did have a bit of concern when, after the first of the usual sequence of reboots, the display reverted to the tiny (Native resolution: 480 x 272) LCD. Not an issue as it turned out as the main display was reactivated before the end of the upgrade and I didn't need to make any inputs in response to data displayed on the small screen.

Of course it would be too simple if the end of the Upgrade process also meant my own work was done. First job was to re-apply the NVidia graphics driver so that the NVidia control panel became available. That allowed me to recover the correct screen resolution and it also fixed a corrupted display issue on the subsidiary LCD. Then I had to uninstall and reinstall the iTracker graphics card fan speed controller as it had "lost" the card. It's an invaluable utility for me as I can use it to stop the graphics fan completely for normal media duties while the GPU still runs at a toasty but acceptable 70°C.

The HDAV driver appeared to be working OK, despite the last installed version being for Vista, but I took the opportunity to upgrade it and then make sure the sound insertion settings were correct. That was followed by a trip to Windows own sound control applet to make sure all the correct modes were enabled there as well. Then a visit to the NVidia control panel to apply my carefully tuned video settings (colour, brightness contrast, gamma, sharpening etc etc).

Finally I wound up Media Center and, disappointingly, had to set it up from scratch so that it knew where the various media libraries were. A quick check showed that DVD and CD playback was fine but mcShoutCast, while working, was complaining about something or other every time it launched so I ran it's own installer and "repaired" the installation, which action appears to have fixed things.

I've yet to test Total Media Theatre. It's not a program I really use as I get far better results for Blu-ray playback using a standalone player. The only disappointment when I re-applied its own settings was that it had decided to be Region B (Europe) instead of its previous Region A. The only reason I maintain this is that it provides me with a means of playing Region A only BDs, should that be a requirement for the future. So I changed the region back to A and in the process lost one of my 5 allowed changes. No big deal really, this time around anyway.

So the bottom line is that the upgrade went extremely well but it was by no means a hands-off affair as a lot of "media PC specific" settings had to be re-applied after the W7 installer had done it's thing. There are also a number of files which the installer orphaned which I'll have to go through but, unlike with the main PC whose upgrade I described previously in this thread, all the "User" data is still in the correct place this time around.

For me the upgrade was well worth the time and risk as Media Center has some significant usability improvements when accessing DVDs and CDs. 8)


PostPosted: Thu Feb 25, 2010 9:52 pm
by Bob Andersson
Hi folks,

I think I've learned the hard way that upgrading Vista to Windows 7 doesn't blow away the cobwebs. My workstation was built last year and I installed Vista x64 and was generally pleased with it. But the time elapsed from the end of the BIOS initialisation to the Windows Log On screen was never stellar, got steadily slower and ended up at a dismal 98 seconds. :shock:

With hindsight my theory is that some unneeded drivers were loading and taking their time failing to initialise but I could never discover what the problem was at the time. Anyway, when Windows 7 came out I did an upgrade, as opposed to a fresh install, as described above but at the end of the day the time Windows 7 took to start showed no improvement. Not having another identical machine with which to make a comparison I just accepted it as, once started, Windows performed just fine.

My mistake! Due to a series of errors in the motherboard controlled RAID 10 array recently, one of which nearly resulted in a catastrophic loss of data, I decided to use a dedicated Adaptec RAID controller to replace the one on the motherboard. The full story belongs elsewhere but the headline number relevant to this thread is that Windows 7 now starts up in 16 seconds instead of the previous 98 seconds. Some of that will be certainly due to hardware improvements but the discrepancy is so shocking that I have to conclude that Windows 7 didn't blow any of those cobwebby bits left over from Vista away at all. I now have to admit I was wrong and that, if you can possibly do so, a fresh install is the way to go. :oops: :idea: