Lens scratches on Canon 330HS ... on two units so far

DSLRs, compacts, lenses and flashes. Discuss all things Canon here!

Moderators: Bob Andersson, Thomas, Bjorn van Sinttruije

Lens scratches on Canon 330HS ... on two units so far

Postby dhansonca » Sun Dec 14, 2014 8:56 pm

Hello forum members,

I have a technical question about whether others are experiencing lens scratches on the point-and-shoot Canon 330HS unit(s). I believe this is happening when the lens cover is not fully opening when the unit is powering on.

I bought a 330HS unit before the summer and thought one of my children had inadvertently scratched the lens when using it and then went out to buy a new unit (now reduced in price). The same problem has re-occurred and after trolling the internet it seems others have had the same problem, which is basically that the retracting lens cover is not opening properly (sticking) and as a result, it scratching the front element of the lens. :(

I have not yet gone to Canon Canada to see if they will replace or fix the unit BUT ... what I'm really wanting to know is if the successor unit, the Canon 340HS has the same problem or symptoms. I did not experience this problem until taking 20 or 30,000 pictures on the unit...BUT I had a previous SD700 unit that did not have this problem at all.

Any ideas, related information or similar experience (and what was done about it) would be most appreciated.

Regards,
D. Hanson in Toronto
dhansonca
 
Posts: 1
Joined: Sun Dec 14, 2014 8:41 pm

Return to Canon

Who is online

Users browsing this forum: No registered users and 2 guests